[SOLVED] Successful Reindex, But catalog_category_product_index Table Still Empty

Please LogIn to Reply!

Post By: admin | 26-01-2012 06:35 Reply

 

Dear All,

I’ve the problem since accidentally select all products to disable them, the result is they aren’t shown anymore. I’ve checked around the internet about this and everything is OK like product enable status, In Stock status, quantity etc. Later I found that catalog_category_product_index table was empty.

I’ve tried to reindex everything, also flush the cache but the table is still empty. In addition, I have no problem with reindexing process, all is green and READY. Then I tried to bulk product status update to DISABLED and then ENABLED again, but the problem persist.

Can anyone here face the same problem?
Appreciate all the answers, thanks.

Tedi

 

FOUND OUT THE SOLUTION!

After manually add the required data at the table by ‘cheating’ to the sql query, I got the product displayed.
How to display the sql query? Use this:

$collection $this->getProductCollection();
die(
var_dump((string)$collection->getSelect()));

Now to the main problem, when I disabled the product status at “All Store Views” scope it also DISABLED the other(lower level) store view, BUT if you RE-ENABLED them, it set ENABLED in “All Store Views” ONLY.
So, you need to enabled in your current store view, just change store view option to your current store view and do the mass status update. Yes, it works and I can see that the catalog_category_product_index table is not empty anymore.

Regards,
Tedi

`Reply Or Comment!
Please LogIn to Reply!