Developer mode (front-end red boxes)

Please LogIn to Reply!

Post By: admin | 26-01-2012 06:35 Reply



I’ve just come back to using Magento 1.4, not played with it since 1.2 I think, and obviously things have changed a bit.

One thing I am having trouble finding is the switch in the admin to enable the view on the front-end, where each page block had a red border and a tooltip telling you which themes files were responsible for it.

I’ve enabled the new developer mode in index.php by commenting out the Env. variable check, and that seems to work (I get a stack trace when I broke something) but still no red boxes.

Been trawling the magento site and google for a while now, can anyone help?




K never mind, found it.

I forgot that you had to go into a website’s profile, and that default wouldn’t show it.

If anyone else has this issue I’ll leave this note:

CHange scope in the admin to main website
Go to System->Configuration->Advanced->Developer->Debug

and turn on template path and block hints


Glad you found what you needed.  Welcome to the Magento Community, btw smile


Visit us on Facebook Follow us on Twitter!

Got Questions? Visit Magento Answers


Hello, i have a big problem, i can’t disable the developer mode, even if i turn off System->Configuration->Advanced->Developer->Debug
What is wrong??
I have enabled it because i needed it, but now i have to remove it but i can’t!
I already tried to flush the cache and delete all files in /var/cache and /var/session… but didn’t work.

What can i do? Please help me


I’m having the same issue as well… I turned off template path hints and block names but some of them are still showing :

Where do I turn those off as well?



I got the same problem in Magento 1.6 :-(


Have you cleared your cache? “System” -> “Cache Management” -> Select “Flush Cache Storage”?



Magento Sites Built to Date for Clients: 21
Magento Extensions Built to Date for Clients: 7

If you need a response ASAP, please send me a direct message.

Don’t edit core code...

`Reply Or Comment!
Please LogIn to Reply!