GAP Breaks Site after upgrade to 10.1 on 1.4.2

Please LogIn to Reply!

Post By: admin | 26-01-2012 06:35 Reply

 

Hi, I am getting the following error that causes site to stop working after upgrading to GAP 0.10.1 on Magento 1.4.2

a:5:{i:0;s:86:"Invalid method Fooman_GoogleAnalyticsPlus_Block_Ga::_getOrdersTrackingCode(Array
(
)
)"
;i:1;s:4546:"#0 /home/solidsur/public_html/app/code/community/Fooman/GoogleAnalyticsPlus/Block/Ga.php(122): Varien_Object->__call('_getOrdersTrack...', Array)
#1 /home/solidsur/public_html/app/code/community/Fooman/GoogleAnalyticsPlus/Block/Ga.php(122): Mage_GoogleAnalytics_Block_Ga->_getOrdersTrackingCode()
#2 /home/solidsur/public_html/app/code/community/Fooman/GoogleAnalyticsPlus/Block/Ga.php(92): Fooman_GoogleAnalyticsPlus_Block_Ga->_getOrdersTrackingCode('')

Any help would be greatly appreciated!  Thanks.

 

it seems your base Magento installation is not 100% 1.4.2 in
app/code/core/Mage/GoogleAnalytics/Block/Ga.php you should find a method

protected function _getOrdersTrackingCode()
or the downloaded file
app/code/community/Fooman/GoogleAnalyticsPlus/Block/Ga.php
is not the intended 0.10.1 version
in there you should be able to find
protected function _getOrdersTrackingCode ($accountId2 false)

 Signature 

My Magento Store | Extensions by FOOMAN
Extensions | Speedster | PdfCustomiser | GoogleAnalyticsPlus | OrderManager | All | Support

 

hi,
I upgrade magento from 1.4 to 1.5 and uninstall Fooman_GoogleAnalyticsPlus old ver to latest ver but still i get this error “Invalid method
Fooman_GoogleAnalyticsPlus_Block_Ga::_getOrdersTrackingCode”.

Plz help me how to solve this problem.

Thanks.

 

confirm that you have 0.10.4 installed. Also make sure that if you have previously used the compilation mode that you re-run the process.

 Signature 

My Magento Store | Extensions by FOOMAN
Extensions | Speedster | PdfCustomiser | GoogleAnalyticsPlus | OrderManager | All | Support

 

hi fooman, love your extension works great in one shop only tried to install it on another shop running 1.5 of magento and installed your latest version 10.4, but also get the same error as mentioned above. What should I do with the files and functions you mention?

 

Same problem in Magento Community 1.5.1.0.
GoogleAnalyticsPlus 0.10.5

Update:
Forget my remark. There seemed to be another Ga.php which was used and did not contain the method on which it dumped.

`Reply Or Comment!
Please LogIn to Reply!