Getting my vertical category menu to show up on every page

Please LogIn to Reply!

Post By: admin | 26-01-2012 06:35 Reply

 

I followed the tutorial at: http://www.magentocommerce.com/wiki/how_to_create_a_vertical_left_hand_menu?do=show

I was able to get it working, but only on the home page.
Can anyone offer insight on how to get this to show up on EVERY page of the site that the left col is visible on? or at least the category landing pages?

My site is:
http://74.220.219.59/~saleneto/

 

I assume you have this block

<block type="catalog/navigation" before="-"  name="catalog.vertnav"  template="catalog/navigation/vert_nav.phtml"/>
inside a <catalog_category_default> tag like the tutorial says.
Instead move it inside the <default> tag in the same file.
You should have something like this:
<default>
<
reference name="left">
<
block type="catalog/navigation" before="-" name="catalog.vertnav" template="catalog/navigation/vert_nav.phtml"/>
</
reference>
......
</default>

Clear the cache and it should work.

 Signature 

It’s not a bug. It’s a feature.
http://marius-strajeru.blogspot.com/

 

It is in the <default></default> -which is why I am getting so frustrated - I set the cache to not save in the settings, so all my updates are reflected immediately.
Is there any other possible way to fix this problem?

 

I have even tried to go back to the default left.phtml file - and it will won’t show up - see page
http://74.220.219.59/~saleneto/index.php/women.html - it isn’t there, although it is present on the home page!
Help!

 

I have figured this out !!!

- the tutorial says to tweak the catalog.xml file in the modern directory. It is a mistake. The tutorial should say to tweak the catalog.xml file in this directory listed below instead. IT IS THE ONLY WAY this tutorial will work. Unfortunately wasted several days because of this mistake on the tutorial - hope this saves someone else the effort!

The tutorials says to use THIS file :
app / design / frontend / default / modern / layout / catalog.xml

BUT YOU MUST INSTEAD USE THE FOLLOWING!!!!!!!! OR IT WON’T WORK!

app / design / frontend / base / default / layout / catalog.xml

Hope this helps someone else!

`Reply Or Comment!
Please LogIn to Reply!