Helpful Support Guy Causes Problem. 

Please LogIn to Reply!

Post By: admin | 26-01-2012 06:35 Reply

 

I have had Magento V1.3.3 running for over a year now on a Justhost server without any issues at www.girlsobsession.com

This morning we woke to an "Internal Server Error” on both the site and the Admin.  I contacted my JustHost support guy to see if there were any server issues that they were aware of.  He asked for my cPanel password and said he would have a look.  Shortly after he gets back to me ans says "all fixed your permissions were wrong I’ve changed all your folders to 0755 and all your files to 0644 and it’s working now” I knew straight away that there was going to be trouble and asked if the folders and files Magento needed different permissions for were still set correctly.

He responds "Whats Magento?”

Ohhhhhh NOOOOOO!

The site now shows up all right.  It is there now but it’s very slow to respond at all and is a complete mess.  It looks like there is no Template or CSS being applied to what is displayed.  All content is in tact.  I have changed the permissions on the folders that are changed during setup back to 0777 but it has had no effect.  One other thing I have noticed is that changing the root folder to 0777 throws the same Internal Server Error that we woke up to. 

Any help would be appreciated....

 Signature 

Girls Obsession

 

Hurray.... I know whats wrong!

You are using fooman minify cache and that is why your site is not displaying correctly.

Open up lib/minify and set the file inside, i think its m.php and set it to 777 or 755.

Clear your minify cache folder in VAR and also your Var/Cache folder.

and Wham… should start working.

If you can’t get the minify cache working again, open up you .htaccess file and remove the line about rewrite minify.

 

Infact, easier to explain.

Follow these install instructions.

http://www.magentocommerce.com/magento-connect/FOOMAN/extension/457/fooman-speedster

 

Thanks I think you were on the right track and I did do that but the problem must have run deeper into the structure of the site.  Thank god for backups!!!  I have just restored an earlier version and all is good again.. 

Backup,

Backup,

And then Backup some more!!!!

 Signature 

Girls Obsession

 

Its possible then that the URL rewrite got screwed up then in the database.

Glad you got it sorted though smile

 

Thanks again for your help.  I’m thinking of setting up a mirror that I can just do a redirect to in future if this happens to save all the stress.  As it was the site was down for almost 6 hours while I sorted it out.  A quick redirect would have been great!!

My only concern and the reason I haven’t done anything to date is that I am concerned about getting penalised for duplicate content by the search engines.  What is the right way to set this up?

 Signature 

Girls Obsession

`Reply Or Comment!
Please LogIn to Reply!