Upgrade from 1.5.1.0 to 1.7.0.2 using FRESH INSTALL and ORIGINAL DATABASE - some issues

Please LogIn to Reply!

Post By: admin | 26-01-2012 06:35 Reply

 

I have successfully performed database upgrade with a fresh magento 1.7.0.2 installation.
Followed instructions from manual upgrade using fresh install and original database by Brent Peterson, with some differences.

Exact procedure follows
on Live Server:
1. emptied and disabled magento cache
2. emptied database cache
3. updated indexes
4. database dump
5. www root dump

on Test Server
1. cloned environment (virtual host, apache modules, PHP and MySQL version)
2. installed magento 1.7.0.2 pointing to DB `fresh`
3. deactivated cache
4. reindexed
5. imported live db to `live`
6. updated local.xml to let fresh magento point to `live` database
7. files copy from live dump (using “merge” principle, only add not existing files)
--- app/code/community/* (ALL modules files, since previous tests failed with not all modules copied)
--- app/code/local/* (same as above)
--- app/design/frontend/default/mytheme
--- app/etc/modules/*
--- skin/frontend/default/myskin
--- media/* (media/catalog/product/cache skipped)
--- translation files skipped atm
8. properly chown-ed and chmod-ed
9. launched `nohup php index.php`
10. after 12 hours, the script exited with zero bytes output

just in case anyone is wondering: I have chosen this procedure because live magento files have been messed up by previous developers, creating unexplainable bugs.

well, the upgrade was successful!
Frontend seems to be almost PERFECT! smile

But I got some modules related issues (still checking and counting)
1. All the modules have their own menu labels, so modules exist and get initialized, but in magento connect there are no modules installed (only base modules appear)
2. Group Deals module’s pages are blank (only generic page content is shown)
3. Amasty Product Attribute Grid fails to initialize: got a “Uncaught ReferenceError: pAttribute is not defined” error in JS console

I am about to establish contact with modules developers, but I’m worried about the magento connect issue.
Any suggestion?

 

Hello Enrico,

I’ve sent you an email regarding a fix to the Group Deals blank pages issue.

Regards,
Michael Dragan.

 

Regarding Magento Connect issue, try to run the following command from SSH to sync old pear modules:

./mage sync

 Signature 

Professional Magento Optimized Web Hosting
LiteSpeed Enterprise Servers - PHP & MySQL Optimized for Magento
Providing high-performance Magento hosting since 2008.
50% Off First Month: use coupon code: “magentocommerce”

 
Sindre|ProperHost - 05 September 2012 02:10 AM

Regarding Magento Connect issue, try to run the following command from SSH to sync old pear modules:

./mage sync

Thanks for the suggestion, but it didn’t help… :(
Magento Connect still shows only default 1.7 extensions

`Reply Or Comment!
Please LogIn to Reply!